Akeeba Backup for WordPress requires PHP 7.2.0 or later but your server only has PHP 7.0.33. CONTACT US - Finewal

3130 W. Thomas Rd., Suite 301
Phoenix, AZ 85017

Monday - Friday 7am - 3pm
Closed on Weekends

Contact Us